Переполнение буфера в MaxDB

Дата публикации:
31.08.2006
Всего просмотров:
1181
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MaxDB 7.x
Уязвимые версии: MaxDB 7.6.00.22, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в WebDBM при обработке имен баз данных. Удаленный пользователь может с помощью HTTP запроса, содержащего слишком длинное имя базы, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.mysql.com/products/maxdb/

Решение: Установите последнюю версию (7.6.00.31 или выше) с сайта производителя.

Ссылки: SAP-DB/MaxDB WebDBM remote buffer overflow

или введите имя

CAPTCHA