PHP-инклюдинг в Ay System WCS

Дата публикации:
29.08.2006
Дата изменения:
24.03.2009
Всего просмотров:
4622
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-4440
CVE-2006-4441
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ay System WCS 2.x
Уязвимые версии: Ay System WCS 2.6

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path[ShowProcessHandle]" в различных сценариях. Удаленный пользователь может с помощью специально сформированного запроса выполнит произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/manage/template/standard/main.php?path[ShowProcessHandle]=[file]
http://[host]/manage/template/standard/home.php?path[ShowProcessHandle]=[file]
http://[host]/manage/template/standard/impressum.php?path[ShowProcessHandle]=[file]

URL производителя: www.aysad.net

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Ay System CMS <= 2.6 (main.php) Remote File Include Vulnerability

или введите имя

CAPTCHA