Переполнение буфера в GNU Binutils assembler

Дата публикации:
21.08.2006
Всего просмотров:
998
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU Binutils 2.x
Уязвимые версии: GNU Binutils версии до 2.17

Описание:
Уязвимость позволяет удаленному пользователю выполнит произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных GNU assembler. Удаленный пользователь может с помощью специально сформированного файла вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.gnu.org/software/binutils/

Решение: Установите последнюю версию (2.17) с сайта производителя.

Ссылки: sys-devel/binutils: buffer overflow in gas

или введите имя

CAPTCHA