Множественные уязвимости в PHP

Дата публикации:
18.08.2006
Дата изменения:
13.02.2008
Всего просмотров:
3339
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-4481
CVE-2006-4482
CVE-2006-4483
CVE-2006-4484
CVE-2006-4485
CVE-2006-4486
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
PHP 5.1.x
Уязвимые версии:
PHP версии до 4.4.4
PHP версии до 5.1.5

Описание:
Обнаруженные уязвимости позволяют локальному пользователю обойти некоторые ограничения безопасности, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Отсутствует проверка подтверждения safe_mode и open_basedir в функциях "file_exists()", "imap_open()", and "imap_reopen()".

2. Целочисленное переполнение обнаружено в функциях "str_repeat()" и "wordwrap()" на 64-битных платформах. Удаленный пользователь может вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

3. Злоумышленник может обойти ограничения open_basedir и safe_mode с помощью расширения cURL и realpath кеша.

4. Уязвимость существует из-за ошибки проверки границ данных в функции "LWZReadByte_()" в расширении GD. Удаленный пользователь может с помощью специально сформированного GIF изображения выполнить произвольный код на целевой системе.

5. Уязвимость существует из-за ошибки проверки границ данных в функции "stripos()".

6. Уязвимость существует из-за наличия некорректных ограничений memory_limit на 64-битных платформах.

URL производителя: www.php.net

Решение: Установите последнюю версию (4.4.4 или 5.1.5) с сайта производителя.

Журнал изменений:

13.02.2008
Обновлено описание уязвимостей.

или введите имя

CAPTCHA