Переполнение буфера в ncompress

Дата публикации:
17.08.2006
Всего просмотров:
1095
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ncompress 4.x
Уязвимые версии: ncompress 4.x

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "decompress()" в файле compress42.c. Удаленный пользователь может с помощью специально сформированного потока данных вызвать переполнение буфера и выполнить произвольный код на целевой системе.

Решение: Способов устранения уязвимости не существует в настоящее время. Некоторые производители Linux дистрибутивов выпустили обновление.

или введите имя

CAPTCHA