Межсайтовый скриптинг в CakePHP

Дата публикации:
10.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
1283
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CakePHP 1.x
Уязвимые версии: CakePHP версии до 1.1.7.3363

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии error.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: cakephp.org

Решение: Установите последнюю версию (1.1.7.3363) с сайта производителя.

или введите имя

CAPTCHA