Обход ограничений safe mode в PHP

Дата публикации:
09.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
3428
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
PHP 5.1.x
Уязвимые версии:
PHP 4.4.3 и более ранние версии.
PHP 5.1 и более ранние версии.

Описание:
Уязвимость позволяет локальному пользователю обойти ограничения безопасности.

Уязвимость существует из-за ошибки проверки границ данных в функции "sscanf()" при обработке символа форматной строки "$1s". Злоумышленник может получить доступ к освободившейся памяти и обойти ограничения safe mode.

URL производителя: www.php.net

Решение: Установите последнюю версию из CVS репозитория.

Ссылки: php local buffer underflow could lead to arbitary code execution

или введите имя

CAPTCHA