Отказ в обслуживании в GnuPG

Дата публикации:
05.08.2006
Всего просмотров:
1211
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuPG / gpg 1.4.x
Уязвимые версии: GnuPG / gpg 1.4.4, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в файле parse_packet.c при обработке определенных сообщений. Удаленный пользователь может с помощью специально сформированного сообщения, содержащего слишком длинную строку комментария, потребить все доступные ресурсы на системе и аварийно завершить работу приложения.

URL производителя: www.gnupg.org

Решение: Установите последнюю версию (1.4.5) с сайта производителя.

Ссылки: [Dailydave] GnuPG 1.4.4 fun

или введите имя

CAPTCHA