PHP-инклюдинг в Knusperleicht FileManager

Дата публикации:
04.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
1827
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Knusperleicht FileManager 1.x
Уязвимые версии: Knusperleicht FileManager 1.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "dwl_include_path" в сценарии index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://site.com/[path]/dwl_include_path=evilcode.txt?&cmd=id

URL производителя: knusperleicht.at/index.php?...detail=true

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: FileManager Remote Command Execution

или введите имя

CAPTCHA