Межсайтовый скриптинг в Ajax Chat

Дата публикации:
03.08.2006
Всего просмотров:
2145
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3971
CVE-2006-3972
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ajax Chat 0.x
Уязвимые версии: Ajax Chat 0.1, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "chatid" в сценарии includes/operator_chattranscript.php перед использованием данных в функции "fopen()". Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть произвольные файлы на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "userid" в сценарии visitor/livesupport/chat.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.pcdiscs.co.uk/chat/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA