Переполнение буфера в libmikmod

Дата публикации:
27.07.2006
Дата изменения:
28.01.2009
Всего просмотров:
1720
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libmikmod 3.x
Уязвимые версии: libmikmod 3.2.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "loadChunk()" в файле loaders/load_gt2.cs. Удаленный пользователь может с помощью специально сформированного GT2 файла вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/mikmod/

Решение: Установите последнюю версию 3.2.2 с сайта производителя.

Журнал изменений:

28.01.2009
Изменена секция «Решение».

Ссылки: http://aluigi.altervista.org/adv/lmmgt2ho-adv.txt

или введите имя

CAPTCHA