Обход ограничений безопасности в Ruby

Дата публикации:
13.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
1876
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby 1.8.x
Ruby 1.6.x
Уязвимые версии: Ruby 1.8.4 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности.

1. Уязвимость существует из-за ошибки при обработке функционала "alias". Удаленный пользователь может обойти защиту безопасного уровня и заменить вызываемые методы в доверенном уровне.

2. Уязвимость существует из-за недостаточной проверки данных при работе с директориями. Удаленный пользователь может обойти защиту безопасного уровня и закрыть неиспользуемые потоки директорий.

URL производителя: www.ruby-lang.org/en/

Решение: Установите последнюю версию (1.8.5) с сайта производителя.

или введите имя

CAPTCHA