Переполнение буфера в sipXtapi

Дата публикации:
11.07.2006
Дата изменения:
16.10.2006
Всего просмотров:
1326
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
sipXtapi
Уязвимые версии: sipXtapi

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке границ данных в поле "CSeq". Удаленный пользователь может с помощью специально сформированного поля "CSeq", длиной более 24 байт, вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.sipfoundry.org/sipXtapi/index.html

Решение: Установите последнюю версию из SVN репозитория.

Ссылки: ERNW Security Advisory 02/2006 - Buffer Overflow in sipXtapi (used in AOL Triton)

или введите имя

CAPTCHA