Межсайтовый скриптинг и SQL-инъекция в Papoo

Дата публикации:
11.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
1328
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3571
CVE-2006-3572
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Papoo 2.x
Papoo 3.x
Уязвимые версии: Papoo 3 RC3 и более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "msgid" сценария forumthread.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "titel" и "ausgabe" сценария interna/hilfe.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.papoo.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA