Переполнение буфера при обработке XCF файлов в Gimp

Дата публикации:
07.07.2006
Дата изменения:
17.09.2008
Всего просмотров:
1207
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GIMP 2.x
Уязвимые версии: Gimp 2.2.1 и 2.3.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "xcf_load_vector()" при обработке XCF файлов. Удаленный пользователь может с помощью специально сформированного XCF файла, содержащего слишком длинное значение "num_axes" вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.gimp.org

Решение: Установите последнюю версию (2.2.12) с сайта производителя.

Ссылки: Bug 346742 – Buffer overrun in XCF parsing code
http://bugzilla.gnome.org/show_bug.cgi?id=346742

или введите имя

CAPTCHA