Межсайтовый скриптинг в PHPWebGallery

Дата публикации:
05.07.2006
Дата изменения:
05.07.2006
Всего просмотров:
1118
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PhpWebGallery 1.x
Уязвимые версии: PHPWebGallery 1.5.2 и 1.6.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "keyword" в сценарии comments.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://victim/phpwebgallery/comments.php?keyword=%22%3E[XSS]

URL производителя: www.phpwebgallery.net/eng/index.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PhpWebGallery Cross Site Scripting Vulnerability

или введите имя

CAPTCHA