Переполнение динамической памяти в Gentoo mpg123

Дата публикации:
05.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
2165
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Gentoo Linux 1.x
Уязвимые версии: Gentoo Linux 1.x

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует в пакете mpg123 из-за специфического патча Gentoo, который некорректно терминирует строки. Злоумышленник может обманом заставить пользователя подключится к злонамеренному серверу, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.gentoo.org

Решение: Установите последнюю версию (media-sound/mpg123-0.59s-r11 или выше) с сайта производителя.

Ссылки: mpg123: Heap overflow

или введите имя

CAPTCHA