Множественные уязвимости в MyBB

Дата публикации:
03.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
2646
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3758
CVE-2006-3759
CVE-2006-3760
CVE-2006-3761
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyBB (formerly MyBulletinBoard) 1.x
Уязвимые версии: MyBB 1.0 PR 2 - 1.1.4

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в теге "[url]". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за ошибки в сценарии archive/index.php при определении переменой "KILL_GLOBALS". Удаленный пользователь может перезаписать произвольные файлы на системе.

4. Уязвимость существует из-за неизвестной ошибки и позволяет злоумышленнику управлять пользователями и группами в приложении.

URL производителя: www.mybboard.com

Решение: Установите последнюю версию (1.1.5) с сайта

Ссылки: MyBB1.1.4~Archive Mode(Light) ~ Parameter Extraction(Variable Overwriting
MyBB 1.1.5 Released

или введите имя

CAPTCHA