SQL-инъекция в Xoops MyAds модуле

Дата публикации:
03.07.2006
Всего просмотров:
2754
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3341
CVE-2007-1846
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MyAds 2.x (модуль к Xoops)
<strong>Уязвимые версии: </strong> Xoops MyAds 2.04jp, возможно более ранние версии
<p><strong>Описание: </strong> <br>
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.<p>
Уязвимость существует из-за недостаточной обработки входных данных в параметре "lid" в сценарии annonces-p-f.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:<p>
<i>
ttp://victim/modules/myAds/annonces-p-f.php?op=ImprAnn&lid=-1[code]
</i>
<p><strong>Решение: </strong>Способов устранения уязвимости не существует в настоящее время.


Ссылки: Xoops myAds module SQL-Injection
или введите имя

CAPTCHA