Отказ в обслуживании в GnuPG

Дата публикации:
03.07.2006
Всего просмотров:
1147
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuPG / gpg 1.4.x
Уязвимые версии: GnuPG 1.4.3 и 1.9.20, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в "parse-packet.c" при обработке длины пакета. Удаленный пользователь может с помощью специально сформированного пакета, содержащего слишком большое значение в поле length потребить все доступные ресурсы на системе и вызвать отказ в обслуживании. Дальнейшая эксплуатация уязвимости позволит вызвать целочисленное переполнение буфера и аварийно завершить работу gpg. Для успешной эксплуатации уязвимости должна использоваться опция "--no-armor".

URL производителя: www.gnupg.org

Решение: Установите последнюю версию с сайта производителя.

Ссылки: GnuPG fun

или введите имя

CAPTCHA