Межсайтовый скриптинг в myPHP Guestbook

Дата публикации:
02.07.2006
Дата изменения:
17.10.2006
Всего просмотров:
2786
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
myPHP Guestbook 2.x
Уязвимые версии: myPHP Guestbook 2.0.1 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "comment", "email", "homepage", "id", "name" и "text" в сценарии index.php, в параметрах "comment", "email", "homepage", "number", "name" и "text" в сценарии admin/guestbook.php, и в параметрах "email", "homepage", "icq", "name" и "text" в сценарии admin/edit.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.networkarea.ch/php_mysql_guestbook.html

Решение: Установите последнюю версию (2.0.2) с сайта производителя.

Ссылки: myPHP Guestbook Cross-Site Scripting vulnerability

или введите имя

CAPTCHA