SQL-инъекция в phpTRADER

Дата публикации:
30.06.2006
Дата изменения:
24.03.2009
Всего просмотров:
2342
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpTRADER 4.x
Уязвимые версии: phpTRADER 4.9 SP 5, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "sectio" в сценариях "login.php" "write_newad.php", "newad.php", "printad.php", "askseller.php", "browse.php", "showmemberads.php", "note_ad.php", "abuse.php", "buynow.php" и "confirm_newad.php", в параметре "an" в сценариях "printad.php" и "note_ad.php", в параметре "who" в сценарии "showmemberads.php", и в параметре "adnr" в сценарии "buynow.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.bluehouse-project.de/index.php…showdetails&id=3

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: phpTRADER Multiple SQL injection vuln

или введите имя

CAPTCHA