Переполнение буфера в PrivateWire

Дата публикации:
29.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
1961
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PrivateWire 3.x
Уязвимые версии: PrivateWire 3.7, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или скомпрометировать уязвимую систему.

Уязвимость существует из-за ошибки проверки границ данных в функционале Online Registration при обработке слишком длинных URL. Удаленный пользователь может с помощью специально сформированного GET запроса вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.arx.com/products/privatewire.php

Решение: Установите исправление с сайта производителя.

Ссылки: Buffer Overflow in Algorithmic Researchs PrivateWire Online Registration Facility

или введите имя

CAPTCHA