Межсайтовый скриптинг в e107

Дата публикации:
23.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
4504
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3259
CVE-2006-4757
CVE-2006-4794
CVE-2006-5786
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
e107 0.x
Уязвимые версии: e107 0.7.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "ep" в сценарии search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/search.php?q=&r=0&s=Search&in=1&ex=1&ep=
[code]&be=1&t=1&adv=1&type=all&on=new&time=any&author=

2. Уязвимость существует из-за недостаточной обработки входных данных в поле "Subject" во время создания комментария. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: e107.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: e107 v0.7.5 XSS

или введите имя

CAPTCHA