Переполнение буфера при обработке MIDI файлов в WinAmp

Дата публикации:
22.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
2283
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Winamp 5.x
Уязвимые версии: WinAmp 5.23 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке MIDI файлов в библиотеке in_midi.dll. Удаленный пользователь может с помощью специально сформированного ".mid" файла, содержащего злонамеренный заголовок, вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.winamp.com

Решение: Установите последнюю версию (5.24) с сайта производителя.

Ссылки: Buffer Overflow Vulnerability on WinAmp

или введите имя

CAPTCHA