Множественные уязвимости в CS-Forum

Дата публикации:
21.06.2006
Всего просмотров:
1771
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-3168
CVE-2006-3169
CVE-2006-3170
CVE-2006-3171
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие системных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CS-Forum 0.x
Уязвимые версии: CS-Forum 0.81, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "id" и "debut" в сценарии read.php и в параметрах "search" и "debut" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного URL выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "msg_result" и "rep_titre" в сценарии read.php, в параметрах "id" и "parent" в сценарии ajouter.php, и в параметрах файла куки "CSForum_nom", "CSForum_mail" и "CSForum_url". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценарий в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "email" в сценарии ajouter.php перед вызовом функции mail(). Удаленный пользователь может внедрить произвольные заголовки в email сообщение.

URL производителя: www.comscripts.com/scripts/php.cs-forum.643.html

Решение: Установите последнюю версию (0.82) с сайта производителя.

Ссылки: CS-Forum Multiple Vulnerabilities

или введите имя

CAPTCHA