PHP-инклюдинг в DotClear

Дата публикации:
14.06.2006
Всего просмотров:
763
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DotClear 1.x
Уязвимые версии: DotClear 1.2.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "blog_dc_path" в сценарии layout/prepend.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости должен быть установлен PHP5 и включены опции "register_globals" и "allow_url_fopen".

URL производителя: www.dotclear.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA