Переполнение буфера в WinGate

Дата публикации:
08.06.2006
Дата изменения:
24.03.2009
Всего просмотров:
2416
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WinGate 6.x
Уязвимые версии: WinGate 6.1.2.1094 и 6.1.1.1077, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в WWW Proxy Server. Удаленный пользователь может с помощью специально сформированного HTTP запроса вызвать переполнение стека и выполнить произвольный код на целевой системе. Пример:

POST http://[AAAAAAA....A]/ HTTP/1.0\r\n\r\n

URL производителя: www.wingate.com/product-wingate.php

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: QBik Wingate version 6.1.1.1077 Remote Buffer Overflow

или введите имя

CAPTCHA