Переполнение буфера в Typespeed

Дата публикации:
07.06.2006
Дата изменения:
24.03.2009
Всего просмотров:
1047
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Typespeed 0.x
Уязвимые версии: Typespeed 0.4.4, возможно более ранние версии.

Описание:
Удаленный пользователь может вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки проверки границ данных в функции "addnewword()" во время копирования данных. Удаленный пользователь может вызвать переполнение буфера и аварийно завершить работу приложения.

URL производителя: www.sicom.fi/~bestis/typespeed.html

Решение: Установите последнюю версию с сайта производителя. Некоторые производители Linux систем выпустили обновление.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: New typespeed packages fix arbitrary code execution

или введите имя

CAPTCHA